Search for content in message boards

Solution for TreeSync failure – “related to general tree structure”

Replies: 15

Solution for TreeSync failure – “related to general tree structure”

Posted: 1364649069000
Classification: Query
“The changes in this sync update are related to general tree structure and are not specific to data for people, media, or sources. These changes are needed to bring the trees into sync.”

If you are receiving this message when you attempt to sync, you have probably already discovered your tree is only syncing downwards from Ancestry to FTM, but does not sync upwards from FTM to Ancestry. And, you are looking for a simple solution. After several frustrating days, a lot of attempts at different solutions, and an email to, I have finally found the solution to the problem. It is tedious, but it does work.

After posting a request for help with this issue, I was disappointed to learn from other members the only real solution was to create a new Windows User and run FTM from that User. That just isn’t workable or acceptable to me. I paid good money for the product along with a six-month subscription to I should not have to switch Windows users every time I use FTM, which can be several times throughout the day. (BTW, I purchased FTM Complete – not worth the money. Stick with the Basic product.)

There are no Help topics for this particular sync problem, but there is a page for Troubleshooting sync issues:
I tried them all - compacted, unlinked and relinked trees, deleted user configuration, uninstalled and reinstalled several times with a clean boot. Nothing worked.

I finally broke down and created a new Windows User. That did work. Within the secondary user, I was able to sync without failure. That indicated to me there was a file in either the primary User profile or the User registry that was corrupt. My problem started after FTM crashed, so some file in the User profile must have corrupted when the crash occurred.

Hoping to find the corrupt file under the primary User, I searched the secondary User for all occurrences of “Ancestry”, “Family Tree Maker”, FamilyTreeMaker” and “FTM”. I unlinked my tree, uninstalled FTM, and set about deleting all occurrences of those files/folders under both Users. I then reinstalled and downloaded my Ancestry tree as the primary User. I crossed my fingers and attempted to sync a minor FTM change. It still failed. I reluctantly unlinked my tree and downloaded again as the secondary User.

After a day of switching back and forth between Users, my frustration level peaked. I sent a lengthy email to detailing all of my attempts to resolve the issue. I suggested the problem was located in some obscure file or registry entry that was not named by any of the above searches, and ask they research what that file might be. The reply I received was less than satisfactory. I was told it sounded like I had a corrupt Windows User profile and was probably experiencing problems with other software as well; and suggested I contact Microsoft.

(Side note: If you have been looking for an email address, and haven’t found it at their Contact page, here it is: I found it buried in the last paragraph of one of their Help pages.)

I was still seething over the reply, when 20 minutes later I received a follow-up email asking me to take a survey about the support I received. Since they asked, I told them precisely what I thought. The next day I received another email with a solution that actually did work – well almost. I was directed to their page for “No Internet Connection”, and told to follow the instructions related to date/time settings, Internet Options and system security.

I made the suggested date/time and Internet Option changes, and turned off my firewall/security as recommended. (An interesting note here is that at this page it warns that security must remain off through the registration process to make Registry changes that security software may not allow. Their page for Reinstalling FTM also recommends turning off all security during the install process, but it does not warn to leave it off through the registration process. Like most people, I had turned my security back on before allowing FTM to connect to the internet for registration. This may be an important step – it is hard to know since I ended up combining it with other steps.)

Sadly, that suggestion alone did not work. So, I combined the new instructions with some of my previous attempts, and was delighted that it actually solved the problem. Since Ancestry doesn’t include it in their Troubleshooting pages, I thought I would share it here for anyone who would prefer not to use a secondary Windows User to run FTM. It is tedious, but it does work for the “tree structure” issue; and it is possible it may work for other TreeSync problems as well.


1. Begin by Unlinking your tree from

2. Option - Rename tree: I believe it best to simply abandon anything in FTM and work with a fresh download from But, if you have used a lot of the FTM fields that aren’t found in the tree, you may wish to attempt merging the two files later. If you want to attempt merging the two files, it is necessary to first Rename the tree.

3. Follow the instructions in numbers 3, 5, 6 and 7 here (do not restart FTM):

4. Follow the instructions for “Deleting your user configuration file…” here. (Do not restart FTM – only Delete the user configuration file):

5. Follow the “Manual Removal Steps” and “Clear Out Registry Items…” at this page (Ignore the first section titled “Before manually removing the program, please do the following”):

6. In addition to the files/folders already deleted, delete the following folders:
o C:\Users>[UserName]>AppData>Roaming>FamilyTreeMaker
o C:\Users>[UserName]>AppData>Local>Temp>FTM
o C:\Program Files (x86)>Family Tree Maker

7. Also check the Program Data folder for a long/strangely-named folder made up of numbers and characters. Open that folder to see if there is a file inside named “Family Tree Maker 2012-Files”. If so, delete the “Family Tree Maker 2012-Files” folder:
o C:\Program Data>[32-bit hex name]>Family Tree Maker 2012-Files

8. If you aren’t going to attempt merging the two files (number 2 above), also delete your Family Tree Folder to avoid duplicate media items:
o C:\Users>[UserName]>My Documents>Family Tree Maker

9. Reinstall FTM – making sure to leave security off through the registration process.

10. Download tree

11. Test by making a minor change in FTM and syncing to

12. If you want to merge your old FTM file with the newly downloaded file, follow the instructions here:


Final thoughts on FTM stability:

In reading through some of the sync and other issues reported at this forum, I have noticed that like me, most began with an FTM crash. Through my varying efforts to make this work, I think I have found the problem – it is the working size of the FTM file. Even though the Current Tree tab in FTM shows a relatively small file, that is the size after compacting on close. But once open, it bloats to a much larger size. In my case, the Current Tree tab states my FTM file is 7,527 KB. But once open, the file bloats to 370,029 KB. You can test this yourself by creating a manual backup: File>Backup. When a manual backup is created, it backs up the database without compacting. Now compare the manual backup you just created with the AutoBackup created when FTM is closed. The manual backup is the size of your actual working file. And, that is just on opening. It continues to grow as you make more changes within FTM.

Even compacting then backing up within FTM does not reduce the file by much because FTM is attempting to compact an open file. Compacting is an important component of a database, because it re-indexes fields and corrects database errors. FTM, like most database programs, compacts on close – reducing file size and AutoBackup size. But, FTM’s working bloat is HUGE by comparison to other programs I run. I have Windows 64-bit, 2.8 Ghz dual-core processor with 9 GB RAM, that easily accommodates all other programs I run. The FTM problem is unique.

Not realizing at first how huge the bloat was, and in my exuberance, I was making a lot of changes within FTM that increased the bloat to the point FTM could not handle it. Resulting in the fatal crash. In the last several days, I have added over 600 media items (both public and private); resolved over 500 place names, and added almost 300 Notes and Tasks. But, I have not done so without closing FTM about every 20-30 changes. This allows it to compact and re-index fields before adding more.

The size of the working FTM file is simply too big and unstable to make a lot of changes at one time. By making 20-30 changes then closing the program, one should be able to avoid the head-banging experienced by many after an FTM crash.
SubjectAuthorDate Posted
DNITZ2753 1364649069000 
bojangles2_1 1364663441000 
1_latta 1379392931000 
Charlene Bowm... 1379397569000 
1_latta 1379399127000 
Charlene Bowm... 1379406474000 
chris_rickaby 1379414975000 
1_latta 1379435151000 
jamclo 1379436077000 
1_latta 1379562739000 
per page

Find a board about a specific topic