Search for content in message boards

Still cannot launch FTM 2014 in Windows 8 0 - still wish I had never bought it

Replies: 11

Still cannot launch FTM 2014 in Windows 8 0 - still wish I had never bought it

Posted: 1388691965000
Classification: Query
Hi, I posted a message a week about the fact I wish I had never downloaded FTM 2014.

I was given some good advice here but to no avail. I have a brand new laptop less than six months old. bought with Windows 8 installed on it. Loads of RAM, hard disk space etc. I managed to initially install FTM 2014. It subsequently corrupted my major family tree file - and the backup - and now will not launch.

I followed advice posted here, and deleted files, reinstalled FTM 2014, turned off the virus check. None of this has worked. I have tried for hours.

I have requested an immediate refund from the third party downloader who Ancestry outsourced this to. I am so upset and disappointed. I know many of you have had no problems, but believe me, there is no excuse for a brand new product like FTM 2014 to do these things to my computer and fail to launch. I should not have to be an IT expert to understand how I might fix this either.

Ancestry, this message is for you. Please do more R&D on your products before you launch to market. I don't care how many people think this product works fine. It does not. It is a real shame, because I like your website, but I am now going to move to another program that will not destroy my research files like this one has.

I know this sounds emotional, but that is because this problem is emotional for me. Hours and hours of work. GONE.


SubjectAuthorDate Posted
LeighBCD 1388691965000 
silverfox3280 1388695693000 
LeighBCD 1388703484000 
LeighBCD 1388704175000 
keithnuttle 1388719234000 
seanrough 1389586923000 
LeighBCD 1389600250000 
David Abernat... 1389627010000 
LeighBCD 1389688908000 
LeighBCD 1389689140000 
per page

Find a board about a specific topic