Search for content in message boards

Windows 7 update rendered FTM unusable

Windows 7 update rendered FTM unusable

Posted: 1367404633000
Classification: Query
Edited: 1367404852000
I have Windows 7. Last night my computer installed an update called Windows 7 Service Pack 1. Since then I have been able to open Family Tree Maker (2006), but if I try to navigate to anyone other than the default family page, I receive an error message and the program closes. It does not matter if I try to leave that page through the index or by clicking on a parent or child's name in the family view screen. I will still receive the same error message and the program will then close.

I thought that the update had somehow ruined the FTM installation, so I uninstalled FTM and then attempted to re-install it. However, I can no longer do even that. I am now receiving the same error message I had received earlier every time I try to re-install FTM. I tried to use System Restore to get ride of the so-called 'update' altogether, but that didn't fix the problem either.

This is the error message I am receiving:

"An installation support file
could not be installed.

The process cannot access the file because it is being used by another process."

There are no other programs open when I am trying to re-install FTM, nor were there when I tried to use it before I uninstalled it. I never encountered this problem before my computer installed this so-called 'update.'

Has anyone else seen this?

What can I do to fix this problem?


Re: Windows 7 update rendered FTM unusable

Posted: 1367416302000
Classification: Query
Since the installation support file lists a .dll file, I suspect that your FTM program has been corrupted. Even though you uninstalled FTM, uninstalls can leave pieces of the program behind. .dll files for instance. These remaining file bits, on rare occasions, defeat or interfere with a fresh install. There is a cure which I have used for years to uninstall programs completely so that old file remnants don't interfere with the new install. It has a free 30 day trial, so you could try removing FTM with it to see if that works. It's Revo Uninstaller Pro located at Make sure you click "Scan" after you run the uninstaller and check all the check boxes, then click delete. Hope that helps.

Re: Windows 7 update rendered FTM unusable

Posted: 1367421010000
Classification: Query
Revo Uninstaller also has a free edition that works fine in most cases.

Re: Windows 7 update rendered FTM unusable

Posted: 1367423485000
Classification: Query
Use these steps to COMPLETELY uninstall FTM, then reinstall:

Re: Windows 7 update rendered FTM unusable

Posted: 1367647446000
Classification: Query
Edited: 1367647549000

I installed Revo Uninstaller and followed the steps you mentioned. I then re-installed Family Tree Maker. The program is, however, still unusable. When I try to navigate away from the initial family view screen, I receive an error message and the program then closes.

The message is:

"Microsoft Visual C++ Runtime Library
Runtime Error!
Program:C\Program Files (86)\Family Tree Maker 16\Ftw.exe

This application has requested the Runtime to terminate in an unusual way.
Please contact the application's support team for more information."

I have been using FTM for years and have never encountered this problem before. This all happened because Windows 7 installed an update without my consent. Ever since then FTM has not worked. I used system restore to remove the update, but the problem remains.

Does anyone have any further suggestions on how I can fix this, either from the FTM side or how I can truly get rid of the update since system restore clearly didn't do it properly?

Also, assuming I do get rid of the update, is there anything I can do to prevent my computer from installing automatic updates? I don't want a new 'update' to just cause this problem again as soon as I fix FTM.

Re: Windows 7 update rendered FTM unusable

Posted: 1367714272000
Classification: Query
There's a corrupt file somewhere. Trying removing all instances of Microsoft Visual C++ through the Windows Control Panel. Then reinstall it. The latest version can be found here: It's not likely that a Windows Update caused the problem and you are putting your computer at risk if you don't do the updates.
per page

Find a board about a specific topic