Search for content in message boards

Script Errors in FTM 2012: RESOLVED!

Script Errors in FTM 2012: RESOLVED!

Posted: 1363461683000
Classification: Query
Edited: 1363813636000
----------RESOLUTION UPDATE:---------

Script errors in FTM on Public Member pages were caused by browser add-on toolbars (Ask and/or Yahoo). This resolved my issue:

Remove the toolbars: Start > Control Panel > Programs Uninstall a program > Uninstall (Ask, Yahoo, and etc.) toolbars


Windows 7 Home Premium, Service Pack 1
Family Tree Maker 2012
Chrome (default)
IE 9.0.8112
Firefox 19.0.2

I've noticed that every public member page I open within FTM gives a script error. It doesn't happen with census records or other records. I can even view other web pages within FTM without script errors, but all public member tree pages yield a script error.

I have scoured the message boards and tried all suggestions: adjusted Java settings (to enable) in IE, Chrome, and Firefox. I've made the adjustments to FTM Dashboard (removed checks, restarted, replaced checks, restarted). All to no avail.

I'm still getting the annoying script errors for public member trees. I'll try to reload FTM to see if that might correct the problem.

Has anyone else experienced this and were you able to get it resolved?


Re: Script Errors in FTM 2012

Posted: 1363476143000
Classification: Query
A couple things can cause that error.

First, FTM uses Internet Explorer regardless of what else is on your system. So first thing to do is try opening that public member page in Internet Explorer directly. If you still get the script error, it's not an FTM issue - it's an IE issue. In that case, try clearing IE cookies & temporary internet files and see if that helps:

If you don't get the error in IE but still do in FTM, or if you get it in both & clearing temp files doesn't help, most likely cause is security software mucking with the data coming from's web servers. Disable or reconfigure security software.

Long shot is ISP filtering, you can rule that out by trying with IE on a different computer using the same Internet connection.

Re: Script Errors in FTM 2012

Posted: 1363501545000
Classification: Query
Good suggestions.

No problems with IE. Downloaded Microsoft updates. Cleared cache & history. Upgraded IE to 10. Adjusted security to enable most items. Cleared FTM dashboard check, then relaunched and checked all again. Still having problems with FTM.

Same ISP for ten years. Not running any extra security software. No other problems with any other software.

Error consistently is 's_gi' is undefined. I viewed the page source and the html/javascript is:

....a class="acctHelp" onclick="var s=s_gi('myfamilyancestry');,'o','Global Help');" href="">Get Help...

Seems it is javascript on public member trees for the "Get Help" button. Again, this only happens on public member trees. I've tried several different trees from FTM and receive the script error. Opened the same trees using IE, Chrome, and Firefox with no errors. Opened only within FTM and no errors from the home page. I do receive a script error when I click the "Get Help" on within FTM.

Any other suggestions?

Re: Script Errors in FTM 2012

Posted: 1363531392000
Classification: Query
OK so that's indicating that a Javascript function can't be found - which is going to be a function that's in a file in your browser cache (something in a .js file).

Since it's not hurting anything (i.e. the error itself is the annoyance, nothing useful is broken) try turning off script warnings in IE - see "Method 1" in this article:

Re: Script Errors in FTM 2012

Posted: 1363533360000
Classification: Query
Turning OFF the script warnings is about all one can do, as MOST of these errors are caused by the website and has nothing to do with the browser.

Re: Script Errors in FTM 2012

Posted: 1363584907000
Classification: Query
Turned off script warnings in IE. I'm still getting the errors on public member pages in FTM. Arg!

Installing updates from Microsoft again - nothing to do with browser. Tried the FTM Dashboard suggestions from Ancestry web site KB. No luck. Again, no issues at all with opening the same pages in IE, Chrome, or Firefox.

Reinstalling FTM software to see if that helps.

This one has me stumped.

Re: Script Errors in FTM 2012

Posted: 1363616792000
Classification: Query
I'm having the same problem. I've tried everything you did and it didn't helped. I haven't changed anything on my computer and this just started a few weeks ago. I restored my computer back 2 weeks and that didn't help. I've only use IE for as long as I can remember. I hope someone can fix this.

Re: Script Errors in FTM 2012

Posted: 1363617636000
Classification: Query
can you provide a link to one or more of these pages that are giving you this error?

Re: Script Errors in FTM 2012

Posted: 1363630579000
Classification: Query
It only happens when I use FTM 2012 and do web search and go to any persons tree. Doesn't do it on other records. Last week I called and they tried the link and it didn't do it on their computer. Just called 3 different times today and they sent me e-mails. Check Java, check dashboard, do clean boot, tried it all. I am happy to see someone else besides me has the problem. They say they haven't had anyone else call about this problem. I also restored my computer back 2 weeks to see if it was something I down loaded. Didn't help.

Re: Script Errors in FTM 2012

Posted: 1363634411000
Classification: Query
I was curious about this, I switched to FTM Mac a few months ago but still own FTM2012 so I installed it on my Windows 7 laptop, searched a few public trees & public member photos & stories in Web Search and was not able to reproduce the error. There must be some specific combination of software versions and/or configs that cause this since multiple people are reporting it.

For my system (not getting the error) I have:

-Windows 7 Professional SP1 64-bit (If you're not sure what you have, in FTM click Help > About Family Tree Maker > System Information)
-Internet Explorer 10.0.9200.16521
-FTM version

Since this error is definitely coming from Internet Explorer (which is running within FTM), here are some of my Internet Options settings:

-Security tab: Medium-High, Enable Protected Mode is checked
-Privacy tab: Medium, pop-up blocker is on
-Advanced tab: Tried on/off for "Disable Script Debugging" and "Display a notification about every script error", have not been able to duplicate the error

Since I can't reproduce the error I'm kind of stuck as to how to solve it :) but here's something else to try:

1. Close all programs
2. Start > Control Panel > Network and Internet > Internet Options (*or Start > Control Panel > Internet Options depending on your config)
3. Advanced tab
4. [Reset] button
5. Check "Delete personal settings", then [Reset]

This cleans out a bunch of stuff, maybe it'll help???
per page

Find a board about a specific topic